Extension does not work since last upgrade

Bug reports about this site.
Locked
phil90
Posts: 2
Joined: 09 Jul 2007, 03:20

Extension does not work since last upgrade

Post by phil90 » 09 Jul 2007, 03:22

Hello


The trashmail extension did upgrade yesterday and from then it stop working. It seem to work the same way than before but when it does create an email in fact it does not create a temporary email at all.

Is there something that I shouild modify??

Thanks

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Extension does not work since last upgrade

Post by Admin » 10 Jul 2007, 08:05

phil90 wrote:Hello


The trashmail extension did upgrade yesterday and from then it stop working. It seem to work the same way than before but when it does create an email in fact it does not create a temporary email at all.

Is there something that I shouild modify??

Thanks
Hi, I can't reproduce the error you have. Maybe you have activated Challenge-Response system for automatic emails? If challenge-response system is activated you could only receive emails written by humans.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

phil90
Posts: 2
Joined: 09 Jul 2007, 03:20

Post by phil90 » 10 Jul 2007, 22:35

I don't know why it does not work here and it does work for you.


It is not a matter of Challenge response because I don't receive the email to my inbox that confirm the email has been created and I verfied on your website and the email that I suposetly created does not exist at all and it does happen everytime that I use the extension.


Thank you for your help

I am going to use the website when I need a temporary email.

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Post by Admin » 11 Jul 2007, 10:42

phil90 wrote:I don't know why it does not work here and it does work for you.


It is not a matter of Challenge response because I don't receive the email to my inbox that confirm the email has been created and I verfied on your website and the email that I suposetly created does not exist at all and it does happen everytime that I use the extension.


Thank you for your help

I am going to use the website when I need a temporary email.
Hmmm its very strange. And if I understand, website works. Very strange, some times some mail servers don't accept emails of TrashMail, but if website works, its very strange that it does not work. The extension is open source, if you have Javascript skills you could try to debug it, maybe there is a conflict with another extension.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Post by Admin » 13 Jul 2007, 00:52

phil90 wrote:I don't know why it does not work here and it does work for you.


It is not a matter of Challenge response because I don't receive the email to my inbox that confirm the email has been created and I verfied on your website and the email that I suposetly created does not exist at all and it does happen everytime that I use the extension.


Thank you for your help

I am going to use the website when I need a temporary email.
Hi,
the error has been found: By default when the extension has been new installed, there is no challenge-response value in the preference file prefs.js of Firefox. So the extension set it by default to desactivated. But the extension sends an empty "form_whitelisting" field in the HTTP POST request. So TrashMail generated an internal error message that the extension did not recognized. However I fixed the problem by ignore the error and override the field value by 0.
Now all should be working fine. Thanks very much for your information.

Best regards,
saf
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

5263506
Posts: 1
Joined: 13 Sep 2007, 00:02

Re: Extension does not work since last upgrade

Post by 5263506 » 13 Sep 2007, 00:04

I'm having this problem. Trashmail forwards me an email in a bunch of code and I never get another email after that :(

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Extension does not work since last upgrade

Post by Admin » 25 Sep 2007, 21:48

5263506 wrote:I'm having this problem. Trashmail forwards me an email in a bunch of code and I never get another email after that :(
Is the message base 64 encoded? There are some other users they have the same problem. Its strange, I will try to find out what is wrong, I think its since my last system package update.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Extension does not work since last upgrade

Post by Admin » 24 Jun 2009, 14:46

Bug fixed.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Locked