Slow account creation

This is a general forum about all topics, i.e. TrashMail.net, spam mails, email protection, privacy and other things.

Post Reply
Z
Posts: 189
Joined: 16 Jun 2006, 10:28
Contact:

Slow account creation

Post by Z » 28 May 2007, 11:37

I don't know why, but I think creating new accounts is now very very much slower than it used to be?

Maybe there are some technology changes behind the interface? Or maybe there are just tons of more accounts to be checked. (Indexed poorly?)

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Slow account creation

Post by Admin » 04 Jun 2007, 09:58

Z wrote:I don't know why, but I think creating new accounts is now very very much slower than it used to be?

Maybe there are some technology changes behind the interface? Or maybe there are just tons of more accounts to be checked. (Indexed poorly?)
Hi,

strange I tested it, and it works fast on my site.
Maybe there was again a problem with the Internet line...
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Z
Posts: 189
Joined: 16 Jun 2006, 10:28
Contact:

Re: Slow account creation

Post by Z » 04 Jun 2007, 15:33

Admin wrote:Strange I tested it, and it works fast on my site.
Maybe there was again a problem with the Internet line...
How fast is fast? Something like 100 ms or clearly less than second?

I guess the problem is that front page loads from trashmail.net but form is submitted to ssl.trashmail.net that might be reason why it "seems to take a long time". Because DNS lookups SSL hadling etc.

Usually I'm used to have high "intrasite" speed, because of persistent connections (keep-alive) and request pipelining.

Maybe it was just a bad day. how everything seems to be working pretty quickly. Another reason which might cause system to look really slow is high packet loss. If even one packet is lost then it takes time to retrasmit and RWIN go down.

I guess youre still using that ADSL connection which previously had some problems. And I remember been telling you about high packet loss. I think that's the reason if service runs fast on local interface.

But I guess those problems will be over when you get things going...

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Slow account creation

Post by Admin » 06 Jun 2007, 10:37

Z wrote:
Admin wrote:Strange I tested it, and it works fast on my site.
Maybe there was again a problem with the Internet line...
How fast is fast? Something like 100 ms or clearly less than second?
It must be around 100 ms. But 100 ms is very fast!

Just to compare if I check http://www.microsoft.com I have:
~ $ httping -G -g http://www.microsoft.com/
PING http://www.microsoft.com:80 (http://www.microsoft.com/):
connected to http://www.microsoft.com:80, seq=0 time=449.20 ms
connected to http://www.microsoft.com:80, seq=1 time=377.25 ms
connected to http://www.microsoft.com:80, seq=2 time=349.64 ms
--- http://www.microsoft.com/ ping statistics ---
4 connects, 3 ok, 0.00% failed
round-trip min/avg/max = 349.6/392.0/449.2 ms
Z wrote: I guess the problem is that front page loads from trashmail.net but form is submitted to ssl.trashmail.net that might be reason why it "seems to take a long time". Because DNS lookups SSL hadling etc.
There are two reasons:
- D.o.S. attacks which makes my ADSL line to upload all the time stuff to respond to the D.o.S. requests. My ADSL line is also some times broken...
- The creation makes some database processes. The current database has many entries.

The service will soon move on a new server in a datacenter. I will implement the whitelisting function directly in the datacenter.
Z wrote: Usually I'm used to have high "intrasite" speed, because of persistent connections (keep-alive) and request pipelining.
This is supported on TrashMail.net.
Z wrote: Maybe it was just a bad day. how everything seems to be working pretty quickly. Another reason which might cause system to look really slow is high packet loss. If even one packet is lost then it takes time to retrasmit and RWIN go down.
Exactly because my ADSL connection is very broken some times.
Z wrote: I guess youre still using that ADSL connection which previously had some problems. And I remember been telling you about high packet loss. I think that's the reason if service runs fast on local interface.
Exactly, but I tested the service also via Internet. If you do an ICMP ping on http://www.trashmail.net you will see some times packet loss because of my broken ADSL line. Some times this packet loss are also produced if the SMTP server of trashmail is uploading at full speed to respond to the D.o.S. requests.
Z wrote: But I guess those problems will be over when you get things going...
Exactly, please wait for the whitelisting, this would be the next generation of TrashMail.net.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Z
Posts: 189
Joined: 16 Jun 2006, 10:28
Contact:

Re: Slow account creation

Post by Z » 07 Jun 2007, 08:01


Post Reply