Language always defaults to German

Bug reports about this site.
Post Reply
plaintext
Posts: 21
Joined: 31 Oct 2009, 21:15

Language always defaults to German

Post by plaintext » 05 Apr 2010, 11:31

If I want to edit any of my addresses via the Web-Interface, the pages are always shown in German, even if I want English as my default. I'm using an English version of Firefox, and th URL of the Page seems to contain the correct language (lang=en).

https://ssl.trashmail.net/?API=1&login=1&lang=en&input_...

But the resulting page is always in German. BTW, all the Status-Report mails are also in German, same as for the confirmation mails upon address creation.

Admin
Site Admin
Posts: 1243
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Language always defaults to German

Post by Admin » 12 Apr 2010, 09:00

plaintext wrote:If I want to edit any of my addresses via the Web-Interface, the pages are always shown in German, even if I want English as my default. I'm using an English version of Firefox, and th URL of the Page seems to contain the correct language (lang=en).

https://ssl.trashmail.net/?API=1&login=1&lang=en&input_...

But the resulting page is always in German. BTW, all the Status-Report mails are also in German, same as for the confirmation mails upon address creation.
Normally if you put in the URL lang=en it should be forced as english page.
Did you checked your browser settings that you put english as top language?
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

plaintext
Posts: 21
Joined: 31 Oct 2009, 21:15

Re: Language always defaults to German

Post by plaintext » 12 Apr 2010, 18:01

Very strange. I clicked on Edit in Address-Manager, the page shows up in German, even if the Link contains lang=en.
  • Creating a new address via http://us.trashmail.net/ in English, confirmation page and -mail are in English. Of course this address is not accessible in Address-Manager.
  • Creating another Address via the plugin, everything is in English now, as it should.
  • Clicking again on Address-Manager Edit to verify the 1st step above, you guess it, everything is in English from now on.
I think that my last Upgrade to Firefox 3.6.3 messed up things, as often in the past. Annoying.

Post Reply