Page 1 of 1

bug

Posted: 23 Sep 2007, 10:37
by herve
leger soucis depuis peu, lorsque je creé une adresse je recois un message du genre :

Code: Select all

[TrashMail] Compte créé  ...
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: BASE64
Message-Id: <20070923092647.1FA77239AFB15@trashmail.net>
Date: Sun, 23 Sep 2007 11:26:47 +0200 (CEST)

MjMgU2VwdGVtYmVyIDIwMDcgLSAxMToyNjo0NyBDRVQKCkJvbmpvdXIsCgp2b3VzIG91IHF1ZWxx

dSd1biBkJ2F1dHJlIGEgY3LDqWUgdW4gY29tcHRlIHN1ciBub3RyZSBzaXRlIHdlYiBodHRwOi8v

ZnIudHJhc2htYWlsLm5ldC8uCgpWb3RyZSBvdSBzb24gYWRyZXNzZSBJUCBxdWkgYSDDqXTDqSBs

b2d1w6llIGxvcnMgZGUgbGEgY3LDqWF0aW9uIGR1IGNvbXB0ZSA6IDgyLjIzOC4xODkuMTg5Cgo0

IGNvdXJyaWVscyBkZXN0aW7DqXMgw6AgYnlub2JmdWxAdHJhc2htYWlsLm5ldCB2YSAvIHZvbnQg

ZXRyZSB0cmFuc2ZlcsOpcyDDoCBoZXJ2ZWZveEBnbWFpbC5jb20uCkFwcsOocyB2b3RyZSBjb21w

dGUgc2VyYSDDqWZmYWPDqS4KVm90cmUgYWRyZXNzZSBjb3VycmllbCBqZXRhYmxlIGVzdCB2YWxp

ZGUgcGVuZGFudCA3IGpvdXIocykuCgpWb3VzIHBvdXZleiDDoCB0b3V0IG1vbWVudCBjaGFuZ2Vy

IGxlcyBwcsOpZsOpcmVuY2VzIGRlIHZvdHJlIGNvbXB0ZSBlbiB2b3VzIGxvZ2d1YW50CnN1ciBu

b3RyZSBzaXRlOgpodHRwczovL3NzbC50cmFzaG1haWwubmV0Lz9sb2dpbj0xJmxhbmc9ZnIKUHNl

dWRvbnltZTogYnlub2JmdWwKTW90IGRlIHBhc3NlOiBNTmtidlo5ZjFmLXZ5NgoKT3UgZW4gdXRp

bGlzYW50IGxlIGxpZW4gZGlyZWN0OgpodHRwczovL3NzbC50cmFzaG1haWwubmV0Lz9sb2dpbj0x

Jmxhbmc9ZnImaW5wdXRfbG9naW49Ynlub2JmdWwmaW5wdXRfcGFzc3dkPVdrRjRiMmxOT1hNeGN5

MXBiRFk9CgpTaSB2b3VzIG5lIHZvdWxleiBwbHVzIGRlIGNvbXB0ZSBzdXIgbm90cmUgc2l0ZSwg

w6lmZmFjZXogc2ltcGxlbWVudCB2b3RyZSBjb21wdGUKZW4gYWxsYW50IHN1ciBsZSBsaWVuOgpo

dHRwczovL3NzbC50cmFzaG1haWwubmV0Lz9sYW5nPWZyJmRlbD0xJnVzZXI9Ynlub2JmdWwmcGFz

c3dkPU1Oa2J2WjlmMWYtdnk2CgpTaSB2b3VzIHNvdWhhaXRleiBhdm9pciBkZXMgbm91dmVsbGVz

IGZvbmN0aW9uYWxpdMOpZXMsIG91IHNpIHZvdXMgYXZleiBkZXMKY29tbWVudGFpcmVzLCB2ZXVp

bGxleiBzdnAgdmlzaXRlciBub3RyZSBmb3J1bSBzdXI6Cmh0dHBzOi8vc3NsLnRyYXNobWFpbC5u

ZXQvZm9ydW0vCgpTaSB2b3VzIGF2ZXogZGVzIHF1ZXN0aW9ucywgb3UgcXVlIHZvdXMgdm91bGV6

IHJlcG9ydGVyIHVuIGFidXMsIG4naMOpc2l0ZXogcGFzCsOgIG5vdXMgdmlzaXRlciBzdXLCoDoK

aHR0cDovL2ZyLnRyYXNobWFpbC5uZXQvCg==
et j'ai impression qu'aucun transfert ne se fait non plus.

C'est grave chef? ( ca fait un petit moment que ca dure la )

Re: bug

Posted: 25 Sep 2007, 21:47
by Admin
herve wrote:leger soucis depuis peu, lorsque je creé une adresse je recois un message du genre :

code]]TrashMail] Compte créé ...
...

MjMgU2VwdGVtYmVyIDIwMDcgLSAxMToyNjo0NyBDRVQKCkJvbmpvdXIsCgp2b3VzIG91IHF1ZWxx

dSd1biBkJ2F1dHJlIGEgY3LDqWUgdW4gY29tcHRlIHN1ciBub3RyZSBzaXRlIHdlYiBodHRwOi8v

ZnIudHJhc2htYWlsLm5ldC8uCgpWb3RyZSBvdSBzb24gYWRyZXNzZSBJUCBxdWkgYSDDqXTDqSBs

b2d1w6llIGxvcnMgZGUgbGEgY3LDqWF0aW9uIGR1IGNvbXB0ZSA6IDgyLjIzOC4xODkuMTg5Cgo0

IGNvdXJyaWVscyBkZXN0aW7DqXMgw6AgYnlub2JmdWxAdHJhc2htYWlsLm5ldCB2YSAvIHZvbnQg

ZXRyZSB0cmFuc2ZlcsOpcyDDoCBoZXJ2ZWZveEBnbWFpbC5jb20uCkFwcsOocyB2b3RyZSBjb21w

dGUgc2VyYSDDqWZmYWPDqS4KVm90cmUgYWRyZXNzZSBjb3VycmllbCBqZXRhYmxlIGVzdCB2YWxp

ZGUgcGVuZGFudCA3IGpvdXIocykuCgpWb3VzIHBvdXZleiDDoCB0b3V0IG1vbWVudCBjaGFuZ2Vy

IGxlcyBwcsOpZsOpcmVuY2VzIGRlIHZvdHJlIGNvbXB0ZSBlbiB2b3VzIGxvZ2d1YW50CnN1ciBu

b3RyZSBzaXRlOgpodHRwczovL3NzbC50cmFzaG1haWwubmV0Lz9sb2dpbj0xJmxhbmc9ZnIKUHNl

dWRvbnltZTogYnlub2JmdWwKTW90IGRlIHBhc3NlOiBNTmtidlo5ZjFmLXZ5NgoKT3UgZW4gdXRp

bGlzYW50IGxlIGxpZW4gZGlyZWN0OgpodHRwczovL3NzbC50cmFzaG1haWwubmV0Lz9sb2dpbj0x

Jmxhbmc9ZnImaW5wdXRfbG9naW49Ynlub2JmdWwmaW5wdXRfcGFzc3dkPVdrRjRiMmxOT1hNeGN5

MXBiRFk9CgpTaSB2b3VzIG5lIHZvdWxleiBwbHVzIGRlIGNvbXB0ZSBzdXIgbm90cmUgc2l0ZSwg

w6lmZmFjZXogc2ltcGxlbWVudCB2b3RyZSBjb21wdGUKZW4gYWxsYW50IHN1ciBsZSBsaWVuOgpo

dHRwczovL3NzbC50cmFzaG1haWwubmV0Lz9sYW5nPWZyJmRlbD0xJnVzZXI9Ynlub2JmdWwmcGFz

c3dkPU1Oa2J2WjlmMWYtdnk2CgpTaSB2b3VzIHNvdWhhaXRleiBhdm9pciBkZXMgbm91dmVsbGVz

IGZvbmN0aW9uYWxpdMOpZXMsIG91IHNpIHZvdXMgYXZleiBkZXMKY29tbWVudGFpcmVzLCB2ZXVp

bGxleiBzdnAgdmlzaXRlciBub3RyZSBmb3J1bSBzdXI6Cmh0dHBzOi8vc3NsLnRyYXNobWFpbC5u

ZXQvZm9ydW0vCgpTaSB2b3VzIGF2ZXogZGVzIHF1ZXN0aW9ucywgb3UgcXVlIHZvdXMgdm91bGV6

IHJlcG9ydGVyIHVuIGFidXMsIG4naMOpc2l0ZXogcGFzCsOgIG5vdXMgdmlzaXRlciBzdXLCoDoK

aHR0cDovL2ZyLnRyYXNobWFpbC5uZXQvCg==Z/codeB

et j'ai impression qu'aucun transfert ne se fait non plus.

C'est grave chef? ( ca fait un petit moment que ca dure la )
...

Re: bug

Posted: 25 Sep 2007, 21:58
by herve
je me revoie ca sur gmail et passe par leur portail

Re: bug

Posted: 26 Sep 2007, 08:14
by Admin
herve wrote:je me revoie ca sur gmail et passe par leur portail
Je crois j'ai fixé le bug.
http://www.bigroom.co.uk/blog/php-mail-and-gmail décrit bien le problème
Cela venait du fait que depuis la mise à jour de PHP 4 vers 5, PHP encode tout à caractères envoyé par émail par la commande mail() en base64 avec du utf8. Gmail ne pouvait pas le décoder À cause d'un bug parce que le entêtes des émails contenait des "\r\n" aulieu des "\n". Apparament gmail arreteait de parser les entêtes des émails après un \r\n. Bref, j'ai fixé le problème.

Re: bug

Posted: 26 Sep 2007, 08:16
by Admin
Arf, je viens de voir qu'il y a un probleme sur ce forum avec les caracteres accents... :(

Re: bug

Posted: 26 Sep 2007, 17:32
by herve
genial , merci pour le support de GMail 8)

Re: bug

Posted: 26 Sep 2007, 21:40
by Admin
herve wrote:genial , merci pour le support de GMail 8)
Parfait. Je suis content que tout refonctionne. :D