Server move

This is a forum about all kind of information about TrashMail.net related information, news and outages.

Post Reply
Admin
Site Admin
Posts: 1245
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Server move

Post by Admin » 01 Jul 2010, 12:09

We will move in the next few days from USA back to Germany to a new datacenter.
This will allows us to save costs.

At the same time we switch our technology:
- new OS (TrashMail.net has been ported too)
- a little newer Frontend (beginning of a major change)

The start page will look a little different, using Javascript. There will be no big change for the moment.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

User avatar
Saxtus
Posts: 94
Joined: 05 Oct 2009, 06:13
Location: Athens, Greece

Re: Server move

Post by Saxtus » 01 Jul 2010, 14:44

Excellent news.
How this will affect the services though during transfer?

Admin
Site Admin
Posts: 1245
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Server move

Post by Admin » 02 Jul 2010, 08:22

Saxtus wrote:Excellent news.
How this will affect the services though during transfer?
I set up the TTL of all domain names to 5 minutes.
The moving will take approximately 30 min. I think the service could be down in theory for 35 min, but realistic probably one hour or more depending on your ISP if they accept the 5 min TTL or ignore it.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Admin
Site Admin
Posts: 1245
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Server move

Post by Admin » 03 Jul 2010, 16:12

Server move done.
It took about one hour.

Now I need to fix a few things like the live stats and graphics.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Admin
Site Admin
Posts: 1245
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Server move

Post by Admin » 03 Jul 2010, 16:28

A few problems happened:
I just discovered mailhop does no more accept emails. I removed the server from backup list.

Unfortunately for a minute I removed the MX record of the "@trashmail.net" domain. I corrected this now.
All mails sent to mailhop got 5** error (relay denied).
The mails sent to @trashmail.net in the minute where the record was deleted would have got domain not found message.

The database server max number of connection value was set to low. I increased it. Unfortunately some mails has been refused (with an SMTP error code).

Sorry for this problems, but now it should be fine.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Admin
Site Admin
Posts: 1245
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Server move

Post by Admin » 03 Jul 2010, 17:49

I just fixed sending out of emails over the web interface.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Admin
Site Admin
Posts: 1245
Joined: 16 Jun 2006, 08:55
Location: Germany
Contact:

Re: Server move

Post by Admin » 03 Jul 2010, 18:09

Stats fixed.
Best regards,
Stephan Ferraro
Founder of TrashMail.com
CEO of Aionda GmbH

Post Reply